check for composite version 0.3
[dana/dcompmgr.git] / dcompmgr.c
index 1c4a5f9..542f1ad 100644 (file)
@@ -91,6 +91,12 @@ main(int argc, char **argv)
         display_unref(dpy);
         return 1;
     }
+    if (dpy->composite.major_version <= 0 && dpy->composite.minor_version < 3)
+    {
+        printf(_("composite extension does not support the overlay window"));
+        display_unref(dpy);
+        return 1;
+    }
 
     nscreens = all_screens(dpy, &screens);
     if (nscreens < 1) {