add doxygen to the project. 'make doc' builds the doxygen stuff. you need doxygen...
[dana/openbox.git] / doc / doxygen / Makefile.am
diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
new file mode 100644 (file)
index 0000000..0a09e70
--- /dev/null
@@ -0,0 +1,9 @@
+all:
+
+doc: doxygen.conf
+       @doxygen doxygen.conf
+
+doxygen.conf: doxygen.conf.in
+       @regex_cmd@ -e "s,\@VERSION\@,$(VERSION)," \
+         -e "s,\@basedir\@,`cd $(top_builddir) && pwd`," \
+         doxygen.conf.in > doxygen.conf